
Contents

Please contact Informatik Inc. if you need help.    This is a comprehensive system and you probably 
will need assistance.    For a limited period, Informatik Inc can set up your first database table free of 
charge. If you require a 'simpler' document imaging system with a fixed database and keyword 
searches, consider the Docudex system.    Please contact Informatik Inc at info@informatik.com. 

If you experience VERSION    or COMPATIBILITY errors, please read the COMPATY.TXT file.

About Copyright, Registration, Technical Support, License
Add New Record
Ascii Characters
AutoText, Speed-Write
Clone Records
Database Administration (Create and Modify Database Structure)
Delete Record
Edit Existing Record
Exit
Export, Import Data
Global File Formatting
Hard Returns
Image View, Print
Image Renumber Pages, Delete Pages
Image Index
Print SQL Report
Purge Database
Refine
Restore Entry
Save Image
Save SQL File
Search Record
SQL Query
SQL Expressions and Functions
Tagging Items
Tutorial, Getting Started



Database Administration (Create and Modify the Database Structure)

The Database Administration is a separate sub-system with its own Online Help system. 
 
If you have Microsoft Access database installed on your computer, you may prefer to perform the 
database administrative functions (such as creating or restructuring databases) with Access.

From the Database menu of the main window (all windows closed), choose Database Design.    Or, 
if you are in the Database Selection window, choose Database Design from the Design menu.



Tutorial, Getting Started

For an extensive and updated tutorial, please read the TUTORIAL.TXT file. 



Copyright, Registration, Technical Support

This system was developed by Informatik Inc, P.O. Box 868, Devon, Pennsylvania 19333.    For 
information on program modifications, systems integrations and custom applications, please contact 
Informatik Inc.

This is a copyright-protected shareware product.    If, after review and evaluation, you like the 
software, please register.    Shareware is based on trust, and we hope that all users will register.    
Upon registration and payment of the registration fee, Informatik Inc will send you the latest master 
diskette, a registration certificate and a User Guide.    Registered users will receive technical support 
and software upgrades as specified in the application.

To register

From the About menu, choose 'Registration, Copyright, License' and follow the instructions.

To obtain technical support

From the Help menu, choose Technical Support and follow the instructions.

Infothek is a trademark of Informatik Inc.

© 1994-1995 Informatik Inc
All rights reserved



Add (Post) a New    Record

See also Edit a Record 
First, please read Image - Indexing.

To add a record

You must be in the Data Edit and Indexing window.    You get there by pressing the Data Edit button 
(pencil) in the tool bar, or from the menu.

1. From the Edit menu in the Data Edit and Indexing window, choose Clear Screen, or click the 
Clear button (cross-out).    Generally, this step is not required if all fields are already blank.    
Clearing the screen creates a blank record, ready to be filled in.

2. Enter the data.    To copy the field data from the previous entry, press F3.    See also Clone 
Record and Autotext. Read    also Templates below.

3. Press the Confirm button (checkmark), or choose Update Record from the File menu.

4. The screen is cleared and the system is ready for the next record.

Templates and Sortcuts

Press F3 to repeat the field entry of the previously confirmed record.

For fast input of repetitive data, you can create templates of a group of field entries.    Fill in the fields
that you want to include in the template, then choose Create Template from the Edit menu.    To post 
a template, choose Post Template from the Edit menu or click on Ctrl+F3.

.



Search

You must be in the Data Edit and Indexing window.    You get there by pressing the Data Edit button 
(pencil) in the tool bar, or from the menu.

1. Click the field that you want to search.    

2. Choose the Search menu.    

3. In the dialog box, specify the search characters (or type ***REPORT to access the records of the
SQL report).      

4. Press the Search button.    

The system displays the first matching record.    If there are several matching records, use the 
'Arrows' button to move to the next or prior record.

The search feature filters out the records with matching word patterns.    Only the matched records 
are included in the lineup of records.    To remove the filter, blank out the search box (or enter an 
asterisk) and click the Search button again.



Edit (Change) an Existing Record

See also: Add a New Record
Delete a Record

To edit an existing record

You must be in the Data Edit and Indexing window.    You get there by pressing the Data Edit button 
(pencil) in the tool bar, or from the menu.

1. In the Data Edit and Indexing window, select the record that you want to edit.    Use the arrow 
buttons or perform a search.    See also Search Record.

2. Make the changes to    the record.

3. Press    the Update button (check mark) or choose Update Record from the File menu, or move    
to another record.    Moving to another record automatically updates the changes.

Templates

For fast input of repetitive data, you can create templates of a group of field entries.    Fill in the fields
that you want to include in the template, then choose Create Template from the Edit menu.    To post 
a template, choose Post Template from the Edit menu or click on Ctrl+F3.



Exit

To exit the system, choose Exit from the File menu.



Delete a Record

To delete a single record

You must be in the Data Edit and Indexing window.    You get there by pressing the Data Edit button 
(pencil) in the tool bar, or from the menu.

1. From the Edit menu in the Data Edit and Indexing window, choose Delete Record.

2. Confirm.    

The action cannot be undone.    



Restore Record

To restore a record

In theData Edit and Indexing window,    choose Restore Record from the File menu.    The record will 
be restored to the state of its last update.



Hard Returns

To insert a hard return into the text

1. In a data input field in the Data Edit and Indexing window,    place the insertion point where you 
want to insert a hard return.

2. From the Edit menu, choose Hard Return.



ASCIII Characters

To insert an ASCII character

1. In a data input field in the Data Edit and Indexing window,    place the insertion point where you 
want to insert an ASCII character.

2. From the Edit menu, choose ASCII.

3. From the pop-up list, select the character.



Printing the Report

To print a report

1. Before you print the report, you may want to    adjust the column width.    In the heading of the 
report, point to the column partition line and, while holding the left curser down, move the line to 
the left or right.

2. From the File menu, choose Print Standard Report.    To print the field values vertically, choose 
Print Vertical Report. 

3. The system prompts you to enter a short report heading.    

4. In the Print Dialog, select the printer (if required).

5. Choose OK.



Clone Record

To clone a record

You must be in the Data Edit and Indexing window.    You get there by pressing the Data Edit button 
(pencil) in the tool bar, or from the menu.

1. In the Index Data Edit and Indexing window, select the record that you want    to clone.

2. From the Edit menu, select Clone Record.    The cloned record is displayed.
 
3. Make the necessary changes to the cloned record.

4. Choose Update button.



Image - Renumber Pages, Delete Pages

TIFF and DCX file formats support multiple pages.    When appending an image to an existing file, 
the image is always appended as the last page.    However, the pages can be re-numbered or 
deleted in a separate procedure.

To re-arrange or delete a page

1. Open the document image.    The first page of the image is displayed.

2. From the File menu, choose Renumber/Delete Pages.    The Renumber/Delete Pages 
window appears.

3. In the second column of the grid of page numbers, click the page that you want to move or 
delete. 

4. Choose the Up, Down or Delete button.    To move the page several steps, repeat the 
process for each step.

5. To start over, choose the Refresh button.

6. To execute the move or delete, choose OK.

7. If a page is deleted, the original file is temporarily saved in the SAVEIMG file in the 
application's directory.



Save, Retrieve SQL Query

An SQL query statement can be saved to disk and later be retrieved.

To save an SQL query

1. Create an SQL query.

2. From the File menu, choose Save SQL.

3. In the Save Dialog, select the file name.    Ensure that you are in the correct directory.    

4. Choose OK.

To open (retrieve) an SQL query

1. From the File menu in the Query window, choose Open SQL.

2. In the Open Dialog, select the file name.    You may need to change the directory and/or 
extension name first.    

3. Choose OK.

 



Save Image

To save an in image file

1. In the Image window, display the image.

2. From the File menu, choose Save As.    The Save AS form is displayed.

3. Select the directory.

4. In the Graphics Format list, select the format code (normally TIF).

5. In the File Name box, type the file name.    If the file name has a trailing serial number, you can 
increment the number by pressing the Next Serial Number button.

6. Choose Save.

If the file name already exists, files in the TIFF and DC formats are appended as new pages . 

 



SQL Query

Please read the SQL.TXT file for up-to-date help and examples.    You should periodically 
download the latest SQL.TXT file from the CompuServe library.

1. Open the Query window.    From the Edit menu, choose Clear Screen, or press the Clear 
button (cross-out).    This step is not required if the screen is already cleared.

2. In the SQL Query Builder grid, select the individual fields that you want listed as columns in 
the Query report. Just click the cell in the Select column.    A check mark appears in the 
selected cell.    The fields are already pre-selected.    Click the blue 'Check mark' button to 
include all fields, or the white 'Check mark' button to exclude all fields.    To un-select an 
individual field, place the cursor in the appropriate cell in the Select column and click, or 
press the Delete key.

The selected fields can now be filtered, aggregated (summarized) and sorted, as described 
below.    In addition to the listed database table fields, you can create calculated data 
columns, such as variances, data permutations, etc.    This more advanced but powerful 
application is described at the end of this topic.

3. Click a Source Expression cell.    A listing of available Filter Operators is displayed.    In most 
cases, you will use the '= is' or the 'LIKE' filter operator.    If so, you need not select the filter 
operator; the system will do it for you.    The default filter operator depends on the type of the 
field (numeric or non-numeric)

 4. In the yellow input box, type a filter expression.    The entry can be a single value, a wild card 
word or an expression.    If the filter expression uses a word that is also a field name or a 
system keyword (but unrelated), then place a single quote at the beginning and at the end of 
the word, or place an asterisk at the end of the word.

Examples:

>= 1000        (More or equal 1000)
IN NY, PA, NJ      (just items in NY, PA and NJ)
NOT IN NY,PA,NJ      (all, except in NY, PA and NJ)
BETWEEN 1000 and 2000      (items between 1000 and 2000)
NOT BETWEEN 1000 and 2000      (all, except items between 1000 and 2000)
LIKE SM      (all items starting with the letters 'SM')
< date()      (transactions before today's date)
<> TrxDate        (items that are not equal to the date in the TrxDate field)
Is NULL      (records with a blank field)

For more detail please see SQL Expressions and Functions

5. Complete your query by selecting summary, sorting, formatting operators and column 
totals. These features are optional and are often not required for straightforward queries.    If 
you place filters in several fields, review the 'and/or' parameters.    They are defaulted to 'and'
but you may wish to change them to 'or'.    

6. You can rearrange the sequence (order) in which the fields are displayed in the SQL Report.  
In the SQL Builder grid , select the row that you want to re-arrange.      From the Report 



menu, choose Sequence of Columns and specify the new row position. 

7. Press Query button,    press F8 or choose Run Report from the Report menu.    A listing of 
matching records is displayed.    Adjust the column width, if necessary, by dragging the 
column separator in the column heading.

8. Optionally, for interest, review the SQL statement.    From the Report menu, choose View 
SQL Statement.    If you know the SQL language, feel free to change the SQL statement.    To
close the SQL window, run the SQL query or choose Hide SQL Statement from the Report 
menu.    

If you modify the SQL Statement, it must be run with the Execute SQL Statement in the 
Report menu, NOT with the Query button.

9. You can refine the results with additional filters and sorts.    From the Report menu, select 
Refine Query.

10. To view the detail of one record tabulated in vertical format, select the record and choose 
Summary of Record from the Report menu (Y + CTRL), or simply right-click on the record..

Aggregate and Filter Combo

You can combine an aggregate function with a filter expression.    For example, you may want to list 
the states where the total aggregate sales volume exceeded one million dollars.    In this case insert 
the 'Sum' aggregate in the Sales Volume row, select the >= filter operator and type 1000000 as the 
filter expression.    Check the State row (only the State row should be checked; all other rows should 
normally remain un-checked.)

Create calculated columns

You can create additional 'calculated' columns, such as variances between two fields, calculated 
values, etc.    Click the blank Field cell (second column) with a 'plus' picture in the bottom row.    Type 
the selection formula. 

Examples:

Sales - Budget AS Variance
will display the variance between the Actual and Budget fields and produce a new report 
column labelled 'Variance': 

Datepart("m",InvDate) AS Month
will display the month of the InvDate field and produce a new report column labeled Month. 
(For quarters, use "q", for year, use "yyyy", for day, use "d")

IIF(Actual > Budget ,"Good","Bad")
will display 'Good' if the Actual exceeds Budget, and 'Bad' if Actual is below budget.

Date() - [InvDate]
will display the number of days between a    date shown in the InvDate field and today's date.

If the field name has an embedded space, you must enclose the field name in square brackets, e.g. 



[Sales Amount].    Notice that the keyword 'AS' (or 'as') is required to specify the report column label.  
Without the AS keyword, the column header will be a system generated code.

There is virtually no limit what you can do.    Any good book on SQL will give you further insight into 
the 



Tagging Items

Records on the SQL Report can be tagged.    Tagging is useful if you want to print    or export only a 
few selected records    from a SQL Report.

To tag records

In the SQL Report, double-click the record.    A check mark appears in the first cell of the record.    To 
undo a tag, simply double-click the record again, or press the Delete key.

-or-

Highlight the rows and choose Tag Record from the Edit menu.    To highlight the rows, drag the 
mouse over the records while holding down the left mouse button.

The printing or export functions include only tagged items (if there is at least one tagged item).

Please note that purgeable items cannot be selected with the tag method.    Also, tagging has no 
effect on the Filter and Sort methods in the Refine menu.    The Refine procedure removes all the 
tags. 



SQL Expressions and Functions

See also:  SQL Query

The SQL filter consists of a filter operator and a filter expression.    The format of the filter 
expression depends on the type of filter operator.    Some examples of filter operators and and filter 
expressions are shown below:

= Equal (is)
> More
>= More or equal
< Less
<= Less or equal
<> Not equal

These operators search for exact matches.    The filter expression can be a single value, a formula 
or a reference to a table/field, system date function, etc

1/1/94, 3/31/94-1/31/94
100, 1000+250-(50/2) 
Actual, Budget.    (Where Actual and Budget are field names)
Date(), Date() + 30.    (Date () is a function that returns the current date)

LIKE, NOT LIKE
These operators search for patterns, not exact matches.    The filter expression typically is a word 
(or phrase) with embedded or trailing wild card characters.    There are three types of wild card 
characters:    

? stands for a single character,
# stands for a single digit (0-9),
* stands for a sequence of zero or more characters. 

The system always appends a trailing asterisk (*) and you should not use it at the end of a word. 
(But you can remove it in the SQL statement. To do so, go to the SQL menu).

Examples of filter expressions:

SM returns Smith, Smyth, Smeaton, etc    (remember, the trailing asterisk is not required)
M?LLER returns Miller, Muller, etc
##/12/95 returns all the dates in December 1995
'Miller' returns only Miller names
*Miller' returns names ending with Miller, such as Joe Miller, Kornmiller, etc.

BETWEEN,    NOT BETWEEN
The filter expression must provide the 'from' and the o' values, separated by the 'and'.    Wildcard 
characters are not allowed.

Example:    100 and 200



IN, NOT IN
This very useful (and often overlooked) filter expression returns the records that match the listed 
values.    Don't forget to enter commas between the values.    Wildcards are not permitted.

Example: 100, 110,120,130,140

IS NULLIS, NOT NULL
Returns blank (or not blank) values.    This operator is useful to isolate fields that are blank or not 
blank.

Functions

The supported functions include:    DateSerial, Year, Month, Day, Weekday, TimeSerial, Hour, Minute,
Second, Chr, Asc, Hex, Oct, Val, Fix, Int, Abs, Sgn, Atn, Cos, Sin, Tan, Format, Lcase, Ucase, 
Space, String, Len, Instr, Left, Mid, Right, Trim, Ltrim, Rtrim, DateDiff, DateAdd, DatePartDate, Time,
Now, Iif, IsNull, IsDate, IsDate, IsNumeric.

Some of the most often used functions are explained below. 

Date()
Returns the current system date.

DatePart()
Extracts part of the date, for example the month, the quarter, the year.
Example: DatePart("m",Date()) returns the month of the current date.    To extract the quarter, use 
"q", to extract the year, use "yyyy", to extract the day, use "d".

DateAdd()
Adds days, months or years to a date.
Example: DateAdd("m",1,Date()) adds 1 month to today's date.

DateDiff()
Returns the number of days (etc) between two specified dates
Example: DateDiff("d","3/1/95","1/31/95")
Example: DateDiff(Duedate,Billingdate)
Example: DateDiff(Date(),Billingdate)

Format()
Converts the parameter.

Examples:
Format(Date(),"mm/dd/yy")
Format(Datefield,"dddd")
Format(Datefield,"hh:mm AM/PM")

See Format section below.

Left()
Returns the specified number of characters from the left.



Example: Left(Customer,5) returns the 5 left-most characters of the Customer field.

Right()
Returns the specified number of characters from the right.
Example: Right(Customer,5)

Mid()
Returns the specified number of characters inside a string.
Example: Mid(Customer,4,5) returns 5 characters from the Customer field, starting with the 4th 
character.    If the 'length' parameter is blank, all characters from the starting point are returned.

Len()
Returns the number of characters in a string.
Example: Len(Customer) returns the number of characters in the Customer's name.

InStr()
Returns the character position of a searched string.
Example: InStr("Abcdefg","d") returns 4 (d is the fourth letter in the string).

IIF()
Evaluates the expression and returns the correct answer.
Example: IIF(Due < Date(),"Overdue","").    If the Due date (from the table) is earlier than today's 
date, show "Overdue", otherwise leave blank. 

IsNull(), NOT isNull
Returns TRUE if value is NULL (i.e. invalid)
Example: IFF(IsNull(Billingdate),"INVALID","VALID").    If Billingdate field is invalid (null), return 
INVALID, otherwise return VALID.
Example: IFF (NOT IsNull(Billingdate),"VALID,"INVALID").    Opposite of above example. 

LTrim(). Rtrim(), Trim()
Trims the blank spaces at the left, at the right or both sides.    This function is useful when 
concatenating fields where a field may be blank.    
Example: Rtrim(Firstname & " " & Middlename) & " " & Lastname.    The extra space caused by a 
non-existing middle name is eliminated.

Arithmetic Operators

+, -, *, /  are the basic mathematical functions for adding, deducting, multiplying and dividing.

Use the back-slash (\) for divisions where the result must be an integer (no fractional values).    For 
example: 100 \3 = 33

Use Mod to find the fractional value of a division.    
For example: 100 Mod 3 = .33333

Use the ampersand (&) operator to concatenate text values:.
For example: [City] & ", " & [State] & " " & [Zip] = Devon, Pa 19333
(City, State and Zip are database fields)



Format

The Format function requires specific format keywords.    Please refer to the Format function above.

Popular format keywords are: 

q Quarter of the year (14)
y Day of the year (1366)
yy 2digit year
yyyy 4digit year
m        Month without leading zero
mm        Month with leading zero, e.g. 09
mmm Abbreviated month, e.g. Feb
mmmm Month spelled out, e.g. December
d day without leading zero
dd day with leading zero, e.g. 02
dddAbbreviated day, e.g. Wed
dddd Day spelled out, e.g. Friday
hh Hour
mm              Minute
AM/PM Uses 12hour clock, e.g. 3:15 PM
am/pm Uses 12hour clock, e.g. 3:15 pm
A/P        Uses 12hour clock, e.g. 3:15 P
a/p Uses 12hour clock, e.g. 3:15 p
Currency Amount with currency sign, e.g. $1,000.00
Standard Standard value presentation, e.g. 12,000.00
Percent Expressed as a percentage, e.g. 10%
#,##0.00## Number with minimum of two and maximum of four decimals
Long Date Date format as specified in Windows Control Panel
Medium Date Date format as specified in Windows Control Panel
Short Date Date format as specified inWindows Control Panel



Image - View, Print

To view an image, you must know the image file name.    If the images are indexed in the Infothek 
system, the image file number can be obtained quickly with a query.

The images are always displayed in the currently active image window.    If you want to display 
the image in a new and separate window, select New from the File menu in the Image window 
BEFORE you select the new image.    

To display an image

1. Run a query and identify the record associated with the image.    In the SQL Report, click any
cell of the record.    (The text of the selected cell will become the caption of the image.) 

(To open an image without a query, choose Open from the File menu in the Image window.    
In the dialog box, select the directory and specify the file name.    Ignore paragraph 2 below.)

2. Press the Imaging button in the Query window (not the top toolbar)    or press F12.    The 
Image System window opens and the image is displayed.

3. If necessary, change the viewing aspects.    From the View menu, choose:

Resize Image
Fit to Window (retaining the proportional aspects)
Zoom (see below)
Copy
Rotate 
First, next, prior, last page (applicable only to certain graphics formats)

4. Open the next or prior image, as follows:

Open - Next File Displays the next serialized file.
Open - Prior File Displays the prior serialized file.
Open - Next Query Displays the image in the SQL Query Report.
Open - Prior Query Displays the image in the SQL Query Report.

To print the image
1. Select and display the image as explained above.

2. From the File menu, choose Print.    The Print Image window appears.

3. Specify the Scale Options.    Select 'Scale to Fit' or choose a specific scale.

4. Specify the top and left margins (offset), or select 'Centered'.    The values must be entered in
inches, e.g. 1.125.

5. If the document consists of several pages, specify the 'from' and 'to' page numbers. Pages 
are supported only for TIF and DCX file formats.



6. To set up the printer, choose Setup Printer.    This step is normally not required.

7. Choose OK.

Set the Window Size

The window size can be set for the duration of the session by choosing Set Windows Size from the 
View menu.

Zoom

From the View menu, choose Zoom.    The mouse pointer changes to a cross-hair.      Select a 
section of the image with your mouse.    Drag the mouse while holding down the left button.    The 
selected area is indicated by a 'rubber band'.    Release the mouse.    The zoomed section is 
displayed.    The zoom field can be dragged to another location.    To cancel the zoom field, click on 
the main image or press the Delete key.    AutoZoom (F6) zooms in on the image section previously 
selected.

Copy

To copy a section of the image, choose Copy from the Edit menu.    The mouse pointer changes to a 
cross-hair.      Select a section of the image with your mouse.    Drag the mouse while holding down 
the left button.    The selected area is indicated by a 'rubber band'.    Release the mouse.    The 
selected area is copied to the Windows Clipboard.

Close the Image

An image window may be closed by double-clicking the Control button in the upper-left corner of the 
image window, by choosing Close from the File menu, or by pressing the Delete key.



Image - Indexing

See also:    Add (Post) a New Record 

The indexing of an image consists of two separate actions: 1) You must copy the scanned image to 
a permanent disk file (such as an optical disk), and, 2) you must create an index so that the image 
can be located quickly.    Infothek provides a very powerful and versatile database ideally suited for 
image indexing. The index database and table must be carefully planned and designed.    The index 
database must include a field named 'Imagefile' to accommodate the image file name.

To index an image

If the image does not need to be reformatted (e.g. to TIFF), and if you do not need to relocate 
the image file to another directory, then ignore sections 1 - 5 below and go straight to section 
6.

1. If not already displayed on the screen, open the image file.    From the File menu, choose 
Open and specify the file name.

2. Form the Menu menu, choose Data Edit and Indexing, or click the Edit button (pencil).    

3. For the first image in a session, specify the directory of the permanent image files (such as 
the optical disk).    In the 'Copy to CD' frame at the top of the window, click the Directory field. 
The Document Directory window is displayed.    From the various pull-down lists, select the 
drive and directory and specify the Graphics Format (normally TIFF).    Choose OK.

4. In the Data Edit and Indexing window, in the 'Copy to CD' frame, enter the new file name.    
The file name must conform to the MS DOS file naming convention (maximum eight 
characters).    Do NOT enter an extension name. 

If the destination file name has trailing numerals, for example IMAGE001, the file name can 
be incremented to the next serial number by simply pressing the Increment button.

If you want the system to delete the source image file automatically, after the image is 
committed to the permanent file, check the Auto-Delete box.

If the system should retain the image file name when committing the image to the permanent
file (except the extension name), check the Dub box.

5.  For a new image file, press the Commit New button; to append the image to an existing 
file (TIFF and DCX files only), press the Commit Append button .    The image is now copied 
to the new file.

6. Enter all the fields.    The file name is already defaulted.    See also:    Add (Post) a New 
Record 

7. Press the Confirm button (checkmark).

8. Display the next image.    From the File menu of the image system (not Data    Edit and 
Indexing), choose Open File or Open Next File.    Power users press F5 to quickly retrieve 



the next file.    (Open Next File works only if the file name has numeric suffixes). 

Shortcuts

Press F3 to repeat the field entry from the prior confirmed record.    
Create a 'template' of entries (see Edit menu) and post the template by pressing Ctrl+F3. 

As a shortcut, Ctrl + F12 commits the image and confirms the index in one step.    Shift+Ctrl+F12 
commits the image, confirms the index and moves to the next image in one step.

Setup

The destination directory, the graphics format and the Auto-Dub checkbox can be defaulted on 
logon.    To default any of these fields, create a DEFAULTS.TXT file in the application's directory.    In 
the first line, specify the directory; in the second line specify the graphics format (zero-based 
numeric value.    0 = TIFF, 1 = BMP, etc); in the third line enter 1.    If you require only a partial 
defaulting, leave the non-defaulted lines blank.



Export, Import Data

Before you export data, the data must be selected with a query.    The export will include only the 
records listed in the Query Report.    The export format is standard "ASCII delimited" or 'tab 
delimited'.

To export the records on the SQL Report to a file (Comma and Quote delimited)

1. In the Query window, run a    query to select the records for export.

2. Optionally, tag the records that you wish to export.    See Tagging Items

3. From the File menu, choose Export Data.

4. In the Save Dialog, select the file name.    You may need to change the directory and/or 
extension name first.

5. Choose OK.

To export the records to the Clipboard    (Tab delimited)

1. In the Query window, run a query to select the records for export.

2. Highlight the cell area that you wish to export to the clipboard    (tags are ignored).

3. From the File menu, choose Export to Clipboard.

4. In a spreadsheet application, use the Paste function to copy the data into the spreadsheet.

Import Data

Data is imported via the Data Administration sub-system.    Start up the Database Administration and 
select Import from the Options menu.



Purge the Database

see also: Delete

Before you can purge the database, you must select the purgeable records with a query.    Only the 
records included in the SQL Report will be purged.    Make a complete back-up tape before you run a
purge.

All records in the SQL Query will be purged.    Tagging individual records has no effect on the purge 
action.

To purge the database

1. In the Query window, run a query to select the purgeable records.

2. Review the Report.    Continue, if you are satisfied that all records on the Report can be purged.

3. From the File menu, choose Purge.

4. Carefully read the warning on the Purge Dialog.    Click on the OK button    to continue, or select 
Cancel.



Refine the SQL Query

Sometimes you may not be satisfied with the SQL Report.    Instead of re-creating the SQL 
statement, you can refine the current report with sorting, additional filtering, and totals.

To filter out data from an existing SQL Report.

1. From the Report menu, choose Refine Query | Filter.    The SQL Filter window appears.

2. From the Field list, select the field on which you want to apply a filter.

3. From the Filter Operator list, select the filter operator.

4. In the Filter Expression field, enter the filter expression.

5. Choose OK.

To re-sort the existing SQL Report

1. From the Report menu, choose Refine Query | Sort. 

2. From the list of options, select the field and sort option.



Global File Formatting

Often, the image scanner creases basic uncompressed bitmap files of the image.    The files must 
then be reformatted to a compressed TIFF file and saved in a permanent archive.    Docuthek 
includes a function that reformats single files, selected files or complete directories.

1. From the File menu of DocView imaging window, choose Global File Reformatting.    The Global 
File Reformatting window appears.

2. Double-click on the directory that holds the source files.    To screen out specific file formats, 
specify the Graphics Format.

3. Highlight the files that you want to convert.    To select a single file, simply click on the file name. 
To select several files, click on each file while holding down the Ctrl key.    To select a range, click
on the first file and , while holding down the Shift key, click on the last file.

4. Specify the destination directory (double-click).

5. Specify the new graphics format.

6. the TIFF and DCX formats support multiple pages.    Check the Append box if you want to 
append the files as a new page if the file already exists.

7. If you want to be alerted if a file already exists, check the Alert box.

8. If you want the system to automatically delete the source file after creating the destination file, 
check the Automatic Delete box.

9. Click on OK.



AutoText, Speed-Type

AutoText expands an entered abbreviation code to full a text (Edit screen).    

To set up the AutoText option, you must create a new database named AUTOTEXT.MDB and a table
named AUTOTEXT.    The database must be located in the application's directory.    The table must 
consist of two fields: the Code field and the Text field.    You must also create an index named Index1
with the Code field as the ascending key.    The index must be specified as Primary and Unique.

Once the AutoText database is created, you must populate it with your abbreviation codes.    Simply 
select the Autotext database and enter the abbreviations via the Edit screen.    The abbreviation 
codes must not have any spaces.

The abbreviation code is expanded to its full text when you press Function Key 2 in the Edit screen.

If you need assistance with the setup, please contact Informatik Inc at info@informatik.com.




